Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Python API for MISP" |
| 2 | HOMEPAGE = "https://github.com/MISP/PyMISP" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20" |
| 5 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 6 | SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main" |
| 7 | SRCREV = "7b64c1c9a4fec8ed37c1522b31ab56f30b83f0e1" |
| 8 | S = "${WORKDIR}/git" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 10 | inherit setuptools3 |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | |
| 12 | RDEPENDS_${PN} += " \ |
| 13 | ${PYTHON_PN}-dateutil \ |
| 14 | ${PYTHON_PN}-json \ |
| 15 | ${PYTHON_PN}-jsonschema \ |
| 16 | ${PYTHON_PN}-requests \ |
| 17 | ${PYTHON_PN}-six \ |
| 18 | " |
| 19 | |
| 20 | # Fixes: python3-pymisp requires /bin/bash, but no |
| 21 | # providers found in RDEPENDS_python3-pymisp? [file-rdep |
| 22 | RDEPENDS_${PN} += "bash" |