blob: 9b2efa2cdb29b1901a6e6e14183bcf90676e156f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
Andrew Geisslereef63862021-01-29 15:58:13 -06006SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
7SRCREV = "7b64c1c9a4fec8ed37c1522b31ab56f30b83f0e1"
8S = "${WORKDIR}/git"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
Andrew Geisslereef63862021-01-29 15:58:13 -060010inherit setuptools3
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12RDEPENDS_${PN} += " \
13 ${PYTHON_PN}-dateutil \
14 ${PYTHON_PN}-json \
15 ${PYTHON_PN}-jsonschema \
16 ${PYTHON_PN}-requests \
17 ${PYTHON_PN}-six \
18"
19
20# Fixes: python3-pymisp requires /bin/bash, but no
21# providers found in RDEPENDS_python3-pymisp? [file-rdep
22RDEPENDS_${PN} += "bash"