Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple Python wrapper around the OpenSSL library" |
| 2 | HOMEPAGE = "https://pyopenssl.org/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 5 | |
| 6 | DEPENDS += "openssl ${PYTHON_PN}-cryptography" |
| 7 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 8 | SRC_URI[sha256sum] = "4c231c759543ba02560fcd2480c48dcec4dae34c9da7d3747c508227e0624b51" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | PYPI_PACKAGE = "pyOpenSSL" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 11 | inherit pypi setuptools3 |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | PACKAGES =+ "${PN}-tests" |
| 14 | FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test" |
| 15 | |
| 16 | RDEPENDS_${PN}_class-target = " \ |
| 17 | ${PYTHON_PN}-cryptography \ |
| 18 | ${PYTHON_PN}-six \ |
| 19 | ${PYTHON_PN}-threading \ |
| 20 | " |
| 21 | RDEPENDS_${PN}-tests = "${PN}" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |