Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Wireless daemon for Linux" |
| 2 | HOMEPAGE = "https://iwd.wiki.kernel.org/" |
| 3 | LICENSE = "LGPL-2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09" |
| 5 | |
| 6 | DEPENDS = "ell" |
| 7 | |
| 8 | SRC_URI = "https://www.kernel.org/pub/linux/network/wireless/${BP}.tar.xz \ |
| 9 | file://0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch \ |
| 10 | file://0001-netconfig-Use-s6_addr-instead-of-__in6_u.__u6_addr8.patch \ |
| 11 | " |
| 12 | SRC_URI[sha256sum] = "0225ab81579f027e0fcbf255517f432fcf355d14f3645c36813c71a441dfab55" |
| 13 | |
| 14 | inherit autotools manpages pkgconfig python3native systemd |
| 15 | |
| 16 | PACKAGECONFIG ??= " \ |
| 17 | client \ |
| 18 | monitor \ |
| 19 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 20 | " |
| 21 | PACKAGECONFIG[client] = "--enable-client,--disable-client,readline" |
| 22 | PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor" |
| 23 | PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native" |
| 24 | PACKAGECONFIG[wired] = "--enable-wired,--disable-wired" |
| 25 | PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" |
| 26 | PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" |
| 27 | |
| 28 | EXTRA_OECONF = "--enable-external-ell" |
| 29 | |
| 30 | SYSTEMD_SERVICE:${PN} = " \ |
| 31 | iwd.service \ |
| 32 | ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \ |
| 33 | " |
| 34 | |
| 35 | do_configure:prepend() { |
| 36 | install -d ${S}/build-aux |
| 37 | } |
| 38 | |
| 39 | do_install:append() { |
| 40 | # If client and monitor are disabled, bindir is empty, causing a QA error |
| 41 | rmdir --ignore-fail-on-non-empty ${D}/${bindir} |
| 42 | } |
| 43 | |
| 44 | FILES:${PN} += " \ |
| 45 | ${datadir}/dbus-1 \ |
| 46 | ${nonarch_libdir}/modules-load.d \ |
| 47 | ${systemd_unitdir}/network \ |
| 48 | " |
| 49 | |
| 50 | RDEPENDS:${PN} = "dbus" |
| 51 | |
| 52 | RRECOMMENDS:${PN} = "\ |
| 53 | kernel-module-pkcs7-message \ |
| 54 | kernel-module-pkcs8-key-parser \ |
| 55 | kernel-module-x509-key-parser \ |
| 56 | " |