Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "JSON for modern C++" |
| 2 | HOMEPAGE = "https://nlohmann.github.io/json/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=441793d25a658d58d79a1f87516a6ad1" |
| 6 | |
| 7 | SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \ |
| 8 | " |
| 9 | |
| 10 | SRCREV = "fec56a1a16c6e1c1b1f4e116a20e79398282626c" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit cmake |
| 15 | |
| 16 | EXTRA_OECMAKE += "-DJSON_BuildTests=OFF" |
| 17 | |
| 18 | # nlohmann-json is a header only C++ library, so the main package will be empty. |
| 19 | |
| 20 | RDEPENDS:${PN}-dev = "" |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
| 23 | |
| 24 | # other packages commonly reference the file directly as "json.hpp" |
| 25 | # create symlink to allow this usage |
| 26 | do_install:append() { |
| 27 | ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp |
| 28 | } |