Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | # SPDX-FileCopyrightText: Huawei Inc. |
| 2 | # |
| 3 | # SPDX-License-Identifier: MIT |
| 4 | |
| 5 | HOMEPAGE = "https://lvgl.io/" |
| 6 | DESCRIPTION = "LVGL is an OSS graphics library to create embedded GUI" |
| 7 | SUMMARY = "Light and Versatile Graphics Library" |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a" |
| 10 | |
| 11 | # TODO: Pin upstream release (current is v8.0.3-dev-239-g7b7bed37d) |
| 12 | SRC_URI = "gitsm://github.com/lvgl/lvgl;destsuffix=${S};protocol=https;nobranch=1" |
| 13 | SRCREV = "7b7bed37d3e937c59ec99fccba58774fbf9f1930" |
| 14 | |
| 15 | REQUIRED_DISTRO_FEATURES = "wayland" |
| 16 | |
| 17 | inherit cmake |
| 18 | inherit features_check |
| 19 | |
| 20 | S = "${WORKDIR}/${PN}-${PV}" |
| 21 | |
| 22 | EXTRA_OECMAKE += "-Dinstall:BOOL=ON" |
| 23 | |
| 24 | do_configure:prepend() { |
| 25 | [ -r "${S}/lv_conf.h" ] \ |
| 26 | || sed -e "s|#if 0 /*Set it to \"1\" to enable the content*/|#if 1 // Enabled by ${PN}|g" \ |
| 27 | < "${S}/lv_conf_template.h" > "${S}/lv_conf.h" |
| 28 | } |
| 29 | |
| 30 | FILES:${PN}-dev += "\ |
| 31 | ${includedir}/${PN}/ \ |
| 32 | ${includedir}/${PN}/lvgl/ \ |
| 33 | " |