Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Python bindings for the Apache Thrift RPC system" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" |
| 4 | |
| 5 | SRC_URI[sha256sum] = "87c8205a71cf8bbb111cb99b1f7495070fbc9cabb671669568854210da5b3e29" |
| 6 | |
| 7 | inherit pypi setuptools3 |
| 8 | |
| 9 | # Use different filename to prevent conflicts with thrift itself |
| 10 | PYPI_SRC_URI:append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}" |
| 11 | |
| 12 | RDEPENDS:${PN} += "\ |
| 13 | ${PYTHON_PN}-logging \ |
| 14 | ${PYTHON_PN}-six \ |
| 15 | ${PYTHON_PN}-stringold \ |
| 16 | ${PYTHON_PN}-threading \ |
| 17 | " |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |