Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python." |
| 2 | HOMEPAGE = "https://www.h5py.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "77c7be4001ac7d3ed80477de5b6942501d782de1bbe4886597bdfec2a7ab821f" |
| 8 | |
| 9 | SRC_URI:append = " \ |
| 10 | file://0001-setup_build.py-avoid-absolute-path.patch \ |
| 11 | file://0001-setup.py-Fix-numpy-version.patch \ |
| 12 | " |
| 13 | |
| 14 | inherit pkgconfig pypi setuptools3 |
| 15 | |
| 16 | BBCLASSEXTEND = "native" |
| 17 | |
| 18 | DEPENDS = "python3-pkgconfig-native \ |
| 19 | python3-cython-native \ |
| 20 | python3-numpy-native \ |
| 21 | python3-six-native \ |
| 22 | hdf5-native \ |
| 23 | python3 \ |
| 24 | hdf5 \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS:${PN} = "python3-numpy \ |
| 28 | python3-six \ |
| 29 | python3-json \ |
| 30 | " |
| 31 | |
| 32 | export HDF5_VERSION="1.8.21" |