Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Python parsing module" |
| 2 | HOMEPAGE = "http://pyparsing.wikispaces.com/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "001cad8d467e7a9248ef9fd513f5c0d39afcbcb9a43684101853bd0ab962e479" |
| 7 | |
| 8 | UPSTREAM_CHECK_REGEX = "pyparsing-(?P<pver>.*)\.tar" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | RDEPENDS:${PN} += " \ |
| 13 | ${PYTHON_PN}-datetime \ |
| 14 | ${PYTHON_PN}-debugger \ |
| 15 | ${PYTHON_PN}-json \ |
| 16 | ${PYTHON_PN}-netclient \ |
| 17 | ${PYTHON_PN}-pprint \ |
| 18 | ${PYTHON_PN}-stringold \ |
| 19 | ${PYTHON_PN}-threading \ |
| 20 | " |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |