Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Download, build, install, upgrade, and uninstall Python packages" |
| 2 | HOMEPAGE = "https://pypi.org/project/setuptools" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6" |
| 6 | |
| 7 | inherit pypi setuptools3 |
| 8 | |
| 9 | SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch" |
| 10 | |
| 11 | SRC_URI += "\ |
| 12 | file://0001-change-shebang-to-python3.patch \ |
| 13 | file://0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[sha256sum] = "b0c2461641b58fe30e11d4c3dfba316c513bdf9ec85f9fed0c871c678447205e" |
| 17 | |
| 18 | DEPENDS += "${PYTHON_PN}" |
| 19 | |
| 20 | RDEPENDS:${PN} = "\ |
| 21 | ${PYTHON_PN}-2to3 \ |
| 22 | ${PYTHON_PN}-compile \ |
| 23 | ${PYTHON_PN}-compression \ |
| 24 | ${PYTHON_PN}-ctypes \ |
| 25 | ${PYTHON_PN}-distutils \ |
| 26 | ${PYTHON_PN}-email \ |
| 27 | ${PYTHON_PN}-html \ |
| 28 | ${PYTHON_PN}-json \ |
| 29 | ${PYTHON_PN}-netserver \ |
| 30 | ${PYTHON_PN}-numbers \ |
| 31 | ${PYTHON_PN}-pickle \ |
| 32 | ${PYTHON_PN}-pkg-resources \ |
| 33 | ${PYTHON_PN}-pkgutil \ |
| 34 | ${PYTHON_PN}-plistlib \ |
| 35 | ${PYTHON_PN}-shell \ |
| 36 | ${PYTHON_PN}-stringold \ |
| 37 | ${PYTHON_PN}-threading \ |
| 38 | ${PYTHON_PN}-unittest \ |
| 39 | ${PYTHON_PN}-xml \ |
| 40 | " |
| 41 | |
| 42 | do_install:prepend() { |
| 43 | install -d ${D}${PYTHON_SITEPACKAGES_DIR} |
| 44 | } |
| 45 | |
| 46 | BBCLASSEXTEND = "native nativesdk" |
| 47 | |
| 48 | # The pkg-resources module can be used by itself, without the package downloader |
| 49 | # and easy_install. Ship it in a separate package so that it can be used by |
| 50 | # minimal distributions. |
| 51 | PACKAGES =+ "${PYTHON_PN}-pkg-resources " |
| 52 | FILES:${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*" |
| 53 | RDEPENDS:${PYTHON_PN}-pkg-resources = "\ |
| 54 | ${PYTHON_PN}-compression \ |
| 55 | ${PYTHON_PN}-email \ |
| 56 | ${PYTHON_PN}-plistlib \ |
| 57 | ${PYTHON_PN}-pprint \ |
| 58 | " |