Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Python bindings for GStreamer 1.0" |
| 2 | DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \ |
| 3 | provided by python-gi) " |
| 4 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" |
| 5 | SECTION = "multimedia" |
| 6 | |
| 7 | LICENSE = "LGPLv2.1" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" |
| 9 | |
| 10 | SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz" |
| 11 | SRC_URI[sha256sum] = "533685871305959d6db89507f3b3aa6c765c2f2b0dacdc32c5a6543e72e5bc52" |
| 12 | |
| 13 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" |
| 14 | RDEPENDS:${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" |
| 15 | |
| 16 | PNREAL = "gst-python" |
| 17 | |
| 18 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 19 | |
| 20 | EXTRA_OEMESON += "-Dlibpython-dir=${libdir}" |
| 21 | |
| 22 | # gobject-introspection is mandatory and cannot be configured |
| 23 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 24 | |
| 25 | inherit meson pkgconfig distutils3-base upstream-version-is-even features_check |
| 26 | |
| 27 | # Generating introspection data depends on a combination of native and target |
| 28 | # introspection tools, and qemu to run the target tools. |
| 29 | DEPENDS:append:class-target = " gobject-introspection gobject-introspection-native qemu-native prelink-native" |
| 30 | |
| 31 | # Even though introspection is disabled on -native, gobject-introspection package is still |
| 32 | # needed for m4 macros. |
| 33 | DEPENDS:append:class-native = " gobject-introspection-native" |
| 34 | DEPENDS:append:class-nativesdk = " gobject-introspection-native" |