blob: a32805d129892a2ef1f490f9da6763b856d12c64 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python bindings for GStreamer 1.0"
2DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \
3provided by python-gi) "
4HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
5SECTION = "multimedia"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
9
10SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
11SRC_URI[sha256sum] = "533685871305959d6db89507f3b3aa6c765c2f2b0dacdc32c5a6543e72e5bc52"
12
13DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
14RDEPENDS:${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
15
16PNREAL = "gst-python"
17
18S = "${WORKDIR}/${PNREAL}-${PV}"
19
20EXTRA_OEMESON += "-Dlibpython-dir=${libdir}"
21
22# gobject-introspection is mandatory and cannot be configured
23REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
24
25inherit meson pkgconfig distutils3-base upstream-version-is-even features_check
26
27# Generating introspection data depends on a combination of native and target
28# introspection tools, and qemu to run the target tools.
29DEPENDS:append:class-target = " gobject-introspection gobject-introspection-native qemu-native prelink-native"
30
31# Even though introspection is disabled on -native, gobject-introspection package is still
32# needed for m4 macros.
33DEPENDS:append:class-native = " gobject-introspection-native"
34DEPENDS:append:class-nativesdk = " gobject-introspection-native"