blob: e874e4a5eaac8b90e05d9127323cbf8b946452ea [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Abseil is a cpp library like STL"
2DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
3additional useful libraries like algorithm, container, debugging, hash, memory, \
4meta, numeric, strings, synchronization, time, types and utility"
5HOMEPAGE = "https://abseil.io/"
6SECTION = "libs"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"
9
10PV = "20190808+git${SRCPV}"
11SRCREV = "aa844899c937bde5d2b24f276b59997e5b668bde"
12BRANCH = "lts_2019_08_08"
13SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH} \
14 file://0001-Remove-maes-option-from-cross-compilation.patch \
15 file://0002-Add-forgotten-ABSL_HAVE_VDSO_SUPPORT-conditional.patch \
16 file://0003-Add-fPIC-option.patch \
17 file://0001-Add-RISCV-support-to-GetProgramCounter.patch \
18 file://0001-absl-always-use-asm-sgidefs.h.patch \
Andrew Geisslere231d582020-05-05 08:53:09 -050019 file://0001-Fix-build-on-riscv32.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 "
21
22S = "${WORKDIR}/git"
23
24DEPENDS_append_libc-musl = " libexecinfo "
25
26ASNEEDED_class-native = ""
27ASNEEDED_class-nativesdk = ""
28
29inherit cmake
30
31BBCLASSEXTEND = "native nativesdk"
32ALLOW_EMPTY_${PN} = "1"
33
34python () {
35 arch = d.getVar("TARGET_ARCH")
36
37 if arch == "aarch64":
38 tunes = d.getVar("TUNE_FEATURES")
39 if not tunes:
40 raise bb.parse.SkipPackage("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
41 return
42 pkgn = d.getVar("PN")
43 pkgv = d.getVar("PV")
44 if "crypto" not in tunes:
45 raise bb.parse.SkipPackage("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
46
47 if arch == "x86_64":
48 tunes = d.getVar("TUNE_FEATURES")
49 if not tunes:
50 raise bb.parse.SkipPackage("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
51 return
52 pkgn = d.getVar("PN")
53 pkgv = d.getVar("PV")
54 if "corei7" not in tunes:
55 raise bb.parse.SkipPackage("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
56
57}
58