Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 1 | SUMMARY = "dynamic dispatch decorator for classes and functions" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ea70b07c354e36056bd35e17c9c3face" |
| 4 | |
| 5 | inherit pypi setuptools3 |
| 6 | |
| 7 | SRC_URI[md5sum] = "0e29d2afa806b9b87dadfbed6a0afd6d" |
| 8 | SRC_URI[sha256sum] = "ec7025b2890e7a882ceef95ff82fd154265136af930cab42533070b557d2a15d" |
| 9 | |
| 10 | PYPI_PACKAGE = "dynamic_dispatch" |
| 11 | |
| 12 | DEPENDS += "python3-setuptools-scm-native" |
| 13 | RDEPENDS_${PN} += "\ |
| 14 | python3-typing \ |
| 15 | python3-typeguard \ |
| 16 | " |
| 17 | |
| 18 | BBCLASSEXTEND = "native nativesdk" |