Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "UNIX Shell similar to the Korn shell" |
| 2 | DESCRIPTION = "Zsh is a shell designed for interactive use, although it is also a \ |
| 3 | powerful scripting language. Many of the useful features of bash, \ |
| 4 | ksh, and tcsh were incorporated into zsh; many original features were added." |
| 5 | HOMEPAGE = "http://www.zsh.org" |
| 6 | SECTION = "base/shell" |
| 7 | |
| 8 | LICENSE = "zsh" |
| 9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=1a4c4cda3e8096d2fd483ff2f4514fec" |
| 10 | |
| 11 | DEPENDS = "ncurses bison-native libcap libpcre gdbm groff-native" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz" |
| 14 | SRC_URI[md5sum] = "dfe156fd69b0d8d1745ecf6d6e02e047" |
| 15 | SRC_URI[sha256sum] = "957bcdb2c57f64c02f673693ea5a7518ef24b6557aeb3a4ce222cefa6d74acc9" |
| 16 | |
| 17 | inherit autotools gettext update-alternatives |
| 18 | |
| 19 | EXTRA_OECONF = " \ |
| 20 | --bindir=${base_bindir} \ |
| 21 | --enable-etcdir=${sysconfdir} \ |
| 22 | --enable-fndir=${datadir}/${PN}/${PV}/functions \ |
| 23 | --enable-site-fndir=${datadir}/${PN}/site-functions \ |
| 24 | --with-term-lib='ncursesw ncurses' \ |
| 25 | --with-tcsetpgrp \ |
| 26 | --enable-cap \ |
| 27 | --enable-multibyte \ |
| 28 | --disable-gdbm \ |
| 29 | --disable-dynamic \ |
| 30 | zsh_cv_shared_environ=yes \ |
| 31 | " |
| 32 | |
| 33 | # Configure respects --bindir from EXTRA_OECONF, but then Src/Makefile will read bindir from environment |
| 34 | export bindir="${base_bindir}" |
| 35 | |
| 36 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 37 | |
| 38 | ALTERNATIVE_${PN} = "sh" |
| 39 | ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh" |
| 40 | ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame^] | 41 | ALTERNATIVE_PRIORITY = "90" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 42 | |
| 43 | export AUTOHEADER = "true" |
| 44 | |
| 45 | do_configure () { |
| 46 | gnu-configize --force ${S} |
| 47 | oe_runconf |
| 48 | } |
| 49 | |
| 50 | do_install_append () { |
| 51 | rm -fr ${D}/usr/share |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 52 | rmdir --ignore-fail-on-non-empty ${D}/usr |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 53 | } |
| 54 | |
| 55 | pkg_postinst_${PN} () { |
| 56 | touch $D${sysconfdir}/shells |
| 57 | grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells |
| 58 | grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells |
| 59 | } |
| 60 | |
| 61 | FILES_${PN}-dbg += "\ |
| 62 | ${libdir}/${PN}/${PV}/${PN}/.debug/*.so \ |
| 63 | ${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \ |
| 64 | ${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \ |
| 65 | " |