Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Security-focused ELF files checking tool" |
| 2 | DESCRIPTION = "This is a small set of various PaX aware and related \ |
| 3 | utilities for ELF binaries. It can check ELF binary files and running \ |
| 4 | processes for issues that might be relevant when using ELF binaries \ |
| 5 | along with PaX, such as non-PIC code or executable stack and heap." |
| 6 | HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml" |
| 7 | LICENSE = "GPLv2+" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 9 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | SRC_URI = "https://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 11 | SRC_URI[md5sum] = "a580468318f0ff42edf4a8cd314cc942" |
| 12 | SRC_URI[sha256sum] = "7f4a7f8db6b4743adde7582fa48992ad01776796fcde030683732f56221337d9" |
| 13 | |
| 14 | RDEPENDS_${PN} += "bash" |
| 15 | |
| 16 | export GNULIB_OVERRIDES_WINT_T = "0" |
| 17 | |
| 18 | do_configure_prepend() { |
| 19 | touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README |
| 20 | } |
| 21 | |
| 22 | do_install() { |
| 23 | oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install |
| 24 | } |
| 25 | |
| 26 | BBCLASSEXTEND = "native" |
| 27 | |
| 28 | inherit autotools pkgconfig |
| 29 | |
| 30 | PACKAGECONFIG ??= "" |
| 31 | |
| 32 | PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap" |
| 33 | PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp" |
| 34 | PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools" |
| 35 | |
| 36 | EXTRA_OECONF += "--enable-largefile" |