Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Userspace NFS server v3 protocol" |
| 2 | SECTION = "console/network" |
| 3 | LICENSE = "unfs3" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e" |
| 5 | |
| 6 | # SVN support for upstream version check isn't implemented yet |
| 7 | RECIPE_UPSTREAM_VERSION = "0.9.22.r497" |
| 8 | RECIPE_UPSTREAM_DATE = "Oct 08, 2015" |
| 9 | CHECK_DATE = "Dec 10, 2015" |
| 10 | |
| 11 | DEPENDS = "flex-native bison-native flex" |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 12 | DEPENDS += "libtirpc" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 13 | DEPENDS_append_class-nativesdk = " flex-nativesdk" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 14 | |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 15 | ASNEEDED = "" |
| 16 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 17 | MOD_PV = "497" |
| 18 | S = "${WORKDIR}/trunk" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | # Only subversion url left in OE-Core, use a mirror tarball instead since |
| 20 | # this rarely changes. |
| 21 | # svn://svn.code.sf.net/p/unfs3/code;module=trunk;rev=${MOD_PV};protocol=http |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | # rename the tarball in mirror to avoid clash with user local svn tarball |
| 23 | SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/unfs3-0.9.22.r497.tar.gz \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 24 | file://unfs3_parallel_build.patch \ |
| 25 | file://alternate_rpc_ports.patch \ |
| 26 | file://fix_pid_race_parent_writes_child_pid.patch \ |
| 27 | file://fix_compile_warning.patch \ |
| 28 | file://rename_fh_cache.patch \ |
| 29 | file://relative_max_socket_path_len.patch \ |
| 30 | file://tcp_no_delay.patch \ |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 31 | file://0001-daemon.c-Libtirpc-porting-fixes.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | file://0001-attr-fix-utime-for-symlink.patch \ |
| 33 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 34 | SRC_URI[md5sum] = "2e43e471c77ade0331901c40b8f8e9a3" |
| 35 | SRC_URI[sha256sum] = "21009468a9ba07b72ea93780d025a63ab4e55bf8fc3127803c296f0900fe1bac" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |
| 38 | |
| 39 | inherit autotools |
| 40 | EXTRA_OECONF_append_class-native = " --sbindir=${bindir}" |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 41 | CFLAGS_append = " -I${STAGING_INCDIR}/tirpc" |
| 42 | LDFLAGS_append = " -ltirpc" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 43 | |
| 44 | # Turn off these header detects else the inode search |
| 45 | # will walk entire file systems and this is a real problem |
| 46 | # if you have 2 TB of files to walk in your file system |
| 47 | CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no" |