Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 1 | SUMMARY = "Management suite for extremely large and complex data collections" |
| 2 | DESCRIPTION = "Unique technology suite that makes possible the management of \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 3 | extremely large and complex data collections" |
| 4 | HOMEPAGE = "https://www.hdfgroup.org/" |
| 5 | SECTION = "libs" |
| 6 | |
| 7 | LICENSE = "HDF5" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=57e5351b17591e659eedae107265c606" |
| 9 | |
| 10 | inherit cmake siteinfo |
| 11 | |
| 12 | SRC_URI = " \ |
| 13 | https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8/hdf5-${PV}/src/${BPN}-${PV}.tar.bz2 \ |
| 14 | file://H5lib_settings.c \ |
| 15 | file://H5Tinit-64.c \ |
| 16 | file://H5Tinit-32.c \ |
| 17 | file://0001-cross-compiling-support.patch \ |
| 18 | file://0002-Remove-suffix-shared-from-shared-library-name.patch \ |
| 19 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 20 | SRC_URI[md5sum] = "2d2408f2a9dfb5c7b79998002e9a90e9" |
| 21 | SRC_URI[sha256sum] = "e5b1b1dee44a64b795a91c3321ab7196d9e0871fe50d42969761794e3899f40d" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | FILES_${PN} += "${libdir}/libhdf5.settings ${datadir}/*" |
| 24 | |
| 25 | EXTRA_OECMAKE = " \ |
| 26 | -DTEST_LFS_WORKS_RUN=0 \ |
| 27 | -DTEST_LFS_WORKS_RUN__TRYRUN_OUTPUT=0 \ |
| 28 | -DH5_PRINTF_LL_TEST_RUN=1 \ |
| 29 | -DH5_PRINTF_LL_TEST_RUN__TRYRUN_OUTPUT='8' \ |
| 30 | -DH5_LDOUBLE_TO_LONG_SPECIAL_RUN=0 \ |
| 31 | -DH5_LDOUBLE_TO_LONG_SPECIAL_RUN__TRYRUN_OUTPUT= \ |
| 32 | -DH5_LONG_TO_LDOUBLE_SPECIAL_RUN=0 \ |
| 33 | -DH5_LONG_TO_LDOUBLE_SPECIAL_RUN__TRYRUN_OUTPUT= \ |
| 34 | -DH5_LDOUBLE_TO_LLONG_ACCURATE_RUN=0 \ |
| 35 | -DH5_LDOUBLE_TO_LLONG_ACCURATE_RUN__TRYRUN_OUTPUT= \ |
| 36 | -DH5_LLONG_TO_LDOUBLE_CORRECT_RUN=0 \ |
| 37 | -DH5_LLONG_TO_LDOUBLE_CORRECT_RUN__TRYRUN_OUTPUT= \ |
| 38 | -DH5_NO_ALIGNMENT_RESTRICTIONS_RUN=0 \ |
| 39 | -DH5_NO_ALIGNMENT_RESTRICTIONS_RUN__TRYRUN_OUTPUT= \ |
| 40 | -DCMAKE_INSTALL_PREFIX='${prefix}' \ |
| 41 | -DHDF5_INSTALL_LIB_DIR='${baselib}' \ |
| 42 | " |
| 43 | |
| 44 | do_unpack[postfuncs] += "gen_hd5file" |
| 45 | gen_hd5file() { |
| 46 | install -m 544 ${WORKDIR}/H5lib_settings.c ${S} |
| 47 | install -m 544 ${WORKDIR}/H5Tinit-${SITEINFO_BITS}.c ${S}/H5Tinit.c |
| 48 | } |
| 49 | |
| 50 | do_install_append() { |
| 51 | # Used for generating config files on target |
| 52 | install -m 755 ${B}/bin/H5detect ${D}${bindir} |
| 53 | install -m 755 ${B}/bin/H5make_libsettings ${D}${bindir} |
| 54 | } |
| 55 | |
| 56 | BBCLASSEXTEND = "native" |
| 57 | |
| 58 | SRC_DISTRIBUTE_LICENSES += "HDF5" |