Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | DEPENDS += "shared-mime-info-native shared-mime-info" |
| 2 | |
| 3 | mime_postinst() { |
| 4 | if [ "$1" = configure ]; then |
| 5 | UPDATEMIMEDB=`which update-mime-database` |
| 6 | if [ -x "$UPDATEMIMEDB" ] ; then |
| 7 | echo "Updating MIME database... this may take a while." |
| 8 | $UPDATEMIMEDB $D${datadir}/mime |
| 9 | else |
| 10 | echo "Missing update-mime-database, update of mime database failed!" |
| 11 | exit 1 |
| 12 | fi |
| 13 | fi |
| 14 | } |
| 15 | |
| 16 | mime_postrm() { |
| 17 | if [ "$1" = remove ] || [ "$1" = upgrade ]; then |
| 18 | UPDATEMIMEDB=`which update-mime-database` |
| 19 | if [ -x "$UPDATEMIMEDB" ] ; then |
| 20 | echo "Updating MIME database... this may take a while." |
| 21 | $UPDATEMIMEDB $D${datadir}/mime |
| 22 | else |
| 23 | echo "Missing update-mime-database, update of mime database failed!" |
| 24 | exit 1 |
| 25 | fi |
| 26 | fi |
| 27 | } |
| 28 | |
| 29 | python populate_packages_append () { |
| 30 | import re |
| 31 | packages = d.getVar('PACKAGES', True).split() |
| 32 | pkgdest = d.getVar('PKGDEST', True) |
| 33 | |
| 34 | for pkg in packages: |
| 35 | mime_dir = '%s/%s/usr/share/mime/packages' % (pkgdest, pkg) |
| 36 | mimes = [] |
| 37 | mime_re = re.compile(".*\.xml$") |
| 38 | if os.path.exists(mime_dir): |
| 39 | for f in os.listdir(mime_dir): |
| 40 | if mime_re.match(f): |
| 41 | mimes.append(f) |
| 42 | if mimes: |
| 43 | bb.note("adding mime postinst and postrm scripts to %s" % pkg) |
| 44 | postinst = d.getVar('pkg_postinst_%s' % pkg, True) |
| 45 | if not postinst: |
| 46 | postinst = '#!/bin/sh\n' |
| 47 | postinst += d.getVar('mime_postinst', True) |
| 48 | d.setVar('pkg_postinst_%s' % pkg, postinst) |
| 49 | postrm = d.getVar('pkg_postrm_%s' % pkg, True) |
| 50 | if not postrm: |
| 51 | postrm = '#!/bin/sh\n' |
| 52 | postrm += d.getVar('mime_postrm', True) |
| 53 | d.setVar('pkg_postrm_%s' % pkg, postrm) |
| 54 | bb.note("adding shared-mime-info-data dependency to %s" % pkg) |
| 55 | d.appendVar('RDEPENDS_' + pkg, " shared-mime-info-data") |
| 56 | } |