Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require grub2.inc |
| 2 | |
| 3 | DEPENDS += "autogen-native" |
| 4 | |
| 5 | DEFAULT_PREFERENCE = "-1" |
| 6 | DEFAULT_PREFERENCE_arm = "1" |
| 7 | |
| 8 | PV = "2.00+${SRCPV}" |
| 9 | SRCREV = "87de66d9d83446ecddb29cfbdf7369102c8e209e" |
| 10 | SRC_URI = "git://git.savannah.gnu.org/grub.git \ |
| 11 | file://grub-2.00-fpmath-sse-387-fix.patch \ |
| 12 | file://autogen.sh-exclude-pc.patch \ |
| 13 | file://grub-2.00-add-oe-kernel.patch \ |
| 14 | file://0001-Fix-build-with-glibc-2.20.patch \ |
| 15 | " |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)' |
| 20 | |
| 21 | inherit autotools gettext texinfo |
| 22 | |
| 23 | # configure.ac has code to set this automagically from the target tuple |
| 24 | # but the OE freeform one (core2-foo-bar-linux) don't work with that. |
| 25 | |
| 26 | GRUBPLATFORM_arm = "uboot" |
| 27 | GRUBPLATFORM_aarch64 = "efi" |
| 28 | GRUBPLATFORM ??= "pc" |
| 29 | |
| 30 | EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \ |
| 31 | --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no" |
| 32 | |
| 33 | do_configure_prepend() { |
| 34 | ( cd ${S} |
| 35 | ${S}/autogen.sh ) |
| 36 | } |
| 37 | |
| 38 | do_install_append () { |
| 39 | install -d ${D}${sysconfdir}/grub.d |
| 40 | |
| 41 | } |
| 42 | |
| 43 | # debugedit chokes on bare metal binaries |
| 44 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
| 45 | |
| 46 | RDEPENDS_${PN} = "diffutils freetype" |
| 47 | FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug" |
| 48 | |
| 49 | INSANE_SKIP_${PN} = "arch" |
| 50 | INSANE_SKIP_${PN}-dbg = "arch" |