Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # dosfstools OE build file |
| 2 | # Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved |
| 3 | # Released under the MIT license (see packages/COPYING) |
| 4 | SUMMARY = "DOS FAT Filesystem Utilities" |
| 5 | HOMEPAGE = "http://daniel-baumann.ch/software/dosfstools/" |
| 6 | |
| 7 | SECTION = "base" |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://mkdosfs/COPYING;md5=cbe67f08d6883bff587f615f0cc81aa8" |
| 10 | PR = "r5" |
| 11 | |
| 12 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/${BPN}/${BP}.src.tar.gz/407d405ade410f7597d364ab5dc8c9f6/${BP}.src.tar.gz \ |
| 13 | file://mkdosfs-bootcode.patch \ |
| 14 | file://mkdosfs-dir.patch \ |
| 15 | file://alignment_hack.patch \ |
| 16 | file://msdos_fat12_undefined.patch \ |
| 17 | file://dosfstools-msdos_fs-types.patch \ |
| 18 | file://include-linux-types.patch \ |
| 19 | file://nofat32_autoselect.patch \ |
| 20 | file://fix_populated_dosfs_creation.patch \ |
| 21 | file://0001-Include-fcntl.h-for-getting-loff_t-definition.patch \ |
| 22 | " |
| 23 | |
| 24 | SRC_URI[md5sum] = "407d405ade410f7597d364ab5dc8c9f6" |
| 25 | SRC_URI[sha256sum] = "0eac6d12388b3d9ed78684529c1b0d9346fa2abbe406c4d4a3eb5a023c98a484" |
| 26 | |
| 27 | # Makefile sets this, but we clobber its CFLAGS, so |
| 28 | # add this in here to for sure allow for big files. |
| 29 | # |
| 30 | CFLAGS_append = " -D_FILE_OFFSET_BITS=64" |
| 31 | CFLAGS_append_libc-musl = " -D_GNU_SOURCE" |
| 32 | |
| 33 | do_install () { |
| 34 | oe_runmake "PREFIX=${D}" "SBINDIR=${D}${base_sbindir}" \ |
| 35 | "MANDIR=${D}${mandir}/man8" install |
| 36 | } |
| 37 | |
| 38 | BBCLASSEXTEND = "native" |