Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Additional utilities for the opkg package manager" |
| 2 | SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://code.google.com/p/opkg/" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083" |
| 8 | PROVIDES += "virtual/update-alternatives" |
| 9 | |
| 10 | SRCREV = "53274f087565fd45d8452c5367997ba6a682a37a" |
| 11 | PV = "0.1.8+git${SRCPV}" |
| 12 | |
| 13 | SRC_URI = "git://git.yoctoproject.org/opkg-utils" |
| 14 | |
| 15 | SRC_URI_append_class-native = " file://tar_ignore_error.patch" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 20 | |
| 21 | PYTHONRDEPS = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold" |
| 22 | PYTHONRDEPS_class-native = "" |
| 23 | |
| 24 | PACKAGECONFIG = "python" |
| 25 | PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}" |
| 26 | |
| 27 | do_install() { |
| 28 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install |
| 29 | } |
| 30 | |
| 31 | do_install_append_class-target() { |
| 32 | sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${libdir},g' |
| 33 | } |
| 34 | |
| 35 | PACKAGES =+ "update-alternatives-opkg" |
| 36 | FILES_update-alternatives-opkg = "${bindir}/update-alternatives" |
| 37 | RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth" |
| 38 | RREPLACES_update-alternatives-opkg = "update-alternatives-cworth" |
| 39 | RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth" |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |