Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Python library used to interact with Git repositories" |
| 2 | DESCRIPTION = "GitPython provides object model read and write access to \ |
| 3 | a git repository. Access repository information conveniently, alter the \ |
| 4 | index directly, handle remotes, or go down to low-level object database \ |
| 5 | access with big-files support." |
| 6 | HOMEPAGE = "http://github.com/gitpython-developers/GitPython" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183" |
| 10 | DEPENDS = "python-gitdb" |
| 11 | |
| 12 | SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "4659644b42c41e5e5170c0cd83ed6422" |
| 15 | SRC_URI[sha256sum] = "9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760" |
| 16 | |
| 17 | S = "${WORKDIR}/GitPython-${PV}" |
| 18 | |
| 19 | inherit setuptools |
| 20 | |
| 21 | RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold" |
| 22 | |
| 23 | BBCLASSEXTEND = "nativesdk" |