Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Very high-quality data compression program" |
| 2 | DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \ |
| 3 | Huffman coding. Compression is generally considerably better than that achieved by more conventional \ |
| 4 | LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors." |
| 5 | HOMEPAGE = "http://www.bzip.org/" |
| 6 | SECTION = "console/utils" |
| 7 | LICENSE = "bzip2" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=8;endline=37;md5=40d9d1eb05736d1bfc86cfdd9106e6b2" |
| 9 | PR = "r5" |
| 10 | |
| 11 | SRC_URI = "http://www.bzip.org/${PV}/${BP}.tar.gz \ |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame^] | 12 | file://fix-bunzip2-qt-returns-0-for-corrupt-archives.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | file://configure.ac;subdir=${BP} \ |
| 14 | file://Makefile.am;subdir=${BP} \ |
| 15 | file://run-ptest" |
| 16 | |
| 17 | SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b" |
| 18 | SRC_URI[sha256sum] = "a2848f34fcd5d6cf47def00461fcb528a0484d8edef8208d6d2e2909dc61d9cd" |
| 19 | |
| 20 | PACKAGES =+ "libbz2" |
| 21 | |
| 22 | CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64" |
| 23 | |
| 24 | inherit autotools update-alternatives ptest |
| 25 | |
| 26 | ALTERNATIVE_PRIORITY = "100" |
| 27 | ALTERNATIVE_${PN} = "bunzip2 bzcat" |
| 28 | |
| 29 | #install binaries to bzip2-native under sysroot for replacement-native |
| 30 | EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}" |
| 31 | |
| 32 | do_install_ptest () { |
| 33 | cp -f ${B}/Makefile ${D}${PTEST_PATH}/Makefile |
| 34 | sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile |
| 35 | } |
| 36 | |
| 37 | FILES_libbz2 = "${libdir}/lib*${SOLIBS}" |
| 38 | |
| 39 | PROVIDES_append_class-native = " bzip2-replacement-native" |
| 40 | BBCLASSEXTEND = "native nativesdk" |
| 41 | |