Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Line-oriented text editor" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/ed/" |
| 3 | |
| 4 | LICENSE = "GPLv3+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \ |
| 6 | file://ed.h;endline=20;md5=375a20cc2545ac1115eeb7b323c60ae3 \ |
| 7 | file://main.c;endline=17;md5=14dbb325c1f2d4daf50e0aa5c5038e96" |
| 8 | |
| 9 | SECTION = "base" |
| 10 | |
| 11 | # LSB states that ed should be in /bin/ |
| 12 | bindir = "${base_bindir}" |
| 13 | |
| 14 | SRC_URI = "${GNU_MIRROR}/ed/ed-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "565b6d1d5a9a8816b9b304fc4ed9405d" |
| 17 | SRC_URI[sha256sum] = "d5b372cfadf073001823772272fceac2cfa87552c5cd5a8efc1c8aae61f45a88" |
| 18 | |
| 19 | inherit texinfo |
| 20 | |
| 21 | do_configure() { |
| 22 | ${S}/configure |
| 23 | } |
| 24 | |
| 25 | do_install() { |
| 26 | oe_runmake 'DESTDIR=${D}' install |
| 27 | # Info dir listing isn't interesting at this point so remove it if it exists. |
| 28 | if [ -e "${D}${infodir}/dir" ]; then |
| 29 | rm -f ${D}${infodir}/dir |
| 30 | fi |
| 31 | } |