Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Internationalized Domain Name support library" |
| 2 | DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group." |
| 3 | HOMEPAGE = "http://www.gnu.org/software/libidn/" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "LGPLv2.1+ & GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \ |
| 7 | file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 8 | file://lib/idna.h;beginline=6;endline=18;md5=1336e848ca7b8e25767c3c7e8fa38a89 \ |
| 9 | file://src/idn.c;beginline=6;endline=18;md5=56c89e359652a71cda128d75f0ffdac4" |
| 10 | PR = "r1" |
| 11 | |
| 12 | inherit pkgconfig autotools gettext texinfo |
| 13 | |
| 14 | SRC_URI = "http://alpha.gnu.org/gnu/libidn/${BPN}-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "040f012a45feb56168853998bb87ad4d" |
| 17 | SRC_URI[sha256sum] = "98910c2ad664bdf4eed2c2fff88e24f8882636ec9d26669366ff03b469c05ae3" |
| 18 | |
| 19 | do_configure_prepend() { |
| 20 | # this version of libidn copies AC_USE_SYSTEM_EXTENSIONS from |
| 21 | # autoconf CVS because atm the autoconf it uses is a bit old |
| 22 | # now with cross autotool, that macro is already there and this |
| 23 | # local definition causes circular dependency. Actually AC_GNU_SOURCE |
| 24 | # is identical to AC_USE_SYSTEM_EXTENSIONS. So remove all local |
| 25 | # references to the latter here. |
| 26 | sed -i -e "/AC_REQUIRE(\[gl_USE_SYSTEM_EXTENSIONS/d" ${S}/lib/gl/m4/gnulib-comp.m4 |
| 27 | rm -f ${S}/lib/gl/m4/extensions.m4 |
| 28 | } |
| 29 | |
| 30 | do_install_append() { |
| 31 | rm -rf ${D}${libdir}/Libidn.dll |
| 32 | rm -rf ${D}${datadir}/emacs |
| 33 | } |