Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Software watchdog" |
| 2 | DESCRIPTION = "Watchdog is a daemon that checks if your system is still \ |
| 3 | working. If programs in user space are not longer executed \ |
| 4 | it will reboot the system." |
| 5 | HOMEPAGE = "http://watchdog.sourceforge.net/" |
| 6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=172030&atid=860194" |
| 7 | |
| 8 | LICENSE = "GPL-2.0+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=ecc0551bf54ad97f6b541720f84d6569" |
| 10 | |
| 11 | SRC_URI = "${SOURCEFORGE_MIRROR}/watchdog/watchdog-${PV}.tar.gz \ |
| 12 | file://fixsepbuild.patch \ |
| 13 | file://fix-ping-failure.patch \ |
| 14 | file://watchdog-init.patch \ |
| 15 | file://watchdog-conf.patch" |
| 16 | |
| 17 | SRC_URI[md5sum] = "5b2dba0c593942f4acc100bca0d560c4" |
| 18 | SRC_URI[sha256sum] = "620b2f49e9879f2e85c73d4c1f422f9101e6b38e824fea2414befd8bb6866ad1" |
| 19 | |
| 20 | inherit autotools |
| 21 | inherit update-rc.d |
| 22 | |
| 23 | INITSCRIPT_NAME = "watchdog.sh" |
| 24 | INITSCRIPT_PARAMS = "start 15 1 2 3 4 5 . stop 85 0 6 ." |
| 25 | |
| 26 | RRECOMMENDS_${PN} = "kernel-module-softdog" |
| 27 | |
| 28 | do_install_append() { |
| 29 | install -D ${S}/redhat/watchdog.init ${D}/${sysconfdir}/init.d/watchdog.sh |
| 30 | } |