Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Basic desktop integration functions" |
| 2 | |
| 3 | DESCRIPTION = "The xdg-utils package is a set of simple scripts that provide basic \ |
| 4 | desktop integration functions for any Free Desktop, such as Linux. \ |
| 5 | They are intended to provide a set of defacto standards. \ |
| 6 | The following scripts are provided at this time: \ |
| 7 | xdg-desktop-icon \ |
| 8 | xdg-desktop-menu \ |
| 9 | xdg-email \ |
| 10 | xdg-icon-resource \ |
| 11 | xdg-mime \ |
| 12 | xdg-open \ |
| 13 | xdg-screensaver \ |
| 14 | xdg-terminal \ |
| 15 | " |
| 16 | |
| 17 | LICENSE = "MIT" |
| 18 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a5367a90934098d6b05af3b746405014" |
| 19 | |
| 20 | SRC_URI = "http://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz \ |
| 21 | file://0001-Reinstate-xdg-terminal.patch \ |
| 22 | " |
| 23 | |
| 24 | SRC_URI[md5sum] = "fadf5e7a08e0526fc60dbe3e5b7ef8d6" |
| 25 | SRC_URI[sha256sum] = "7b05558ae4bb8ede356863cae8c42e3e012aa421bf9d45130a570fd209d79102" |
| 26 | |
| 27 | inherit autotools-brokensep distro_features_check |
| 28 | |
| 29 | # The xprop requires x11 in DISTRO_FEATURES |
| 30 | REQUIRED_DISTRO_FEATURES = "x11" |
| 31 | |
| 32 | RDEPENDS_${PN} += "xprop" |