Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "FFmpeg derived postprocessing library" |
| 2 | HOMEPAGE = "http://git.videolan.org/?p=libpostproc.git;a=summary" |
| 3 | SECTION = "libs" |
| 4 | DEPENDS = "libav" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | # because it depends on libav which has commercial flag |
| 9 | LICENSE_FLAGS = "commercial" |
| 10 | |
| 11 | PV = "52.3.0+git${SRCPV}" |
| 12 | |
| 13 | SRCREV = "811db3b957dfde24aef2d0f82e297e5bf552d873" |
| 14 | SRC_URI = "git://github.com/lu-zero/postproc;protocol=https" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools lib_package pkgconfig |
| 19 | |
| 20 | FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math" |
| 21 | BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}" |
| 22 | |
| 23 | EXTRA_FFCONF_armv7a = "--cpu=cortex-a8" |
| 24 | EXTRA_FFCONF ?= "" |
| 25 | |
| 26 | EXTRA_OECONF = " \ |
| 27 | --enable-shared \ |
| 28 | --enable-pthreads \ |
| 29 | --enable-gpl \ |
| 30 | --enable-postproc \ |
| 31 | \ |
| 32 | --cross-prefix=${TARGET_PREFIX} \ |
| 33 | --prefix=${prefix} \ |
| 34 | \ |
| 35 | --arch=${TARGET_ARCH} \ |
| 36 | --target-os="linux" \ |
| 37 | --enable-cross-compile \ |
| 38 | --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \ |
| 39 | --extra-ldflags="${TARGET_LDFLAGS}" \ |
| 40 | --sysroot="${STAGING_DIR_TARGET}" \ |
| 41 | --shlibdir="${libdir}" \ |
| 42 | ${EXTRA_FFCONF} \ |
| 43 | " |
| 44 | |
| 45 | do_configure() { |
| 46 | ${S}/configure ${EXTRA_OECONF} |
| 47 | } |