Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Hardware latency detector" |
| 2 | DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)." |
| 3 | HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git" |
| 4 | SECTION = "tests" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 7 | |
| 8 | require rt-tests.inc |
| 9 | |
| 10 | EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages" |
| 11 | |
| 12 | do_compile() { |
| 13 | oe_runmake hwlatdetect |
| 14 | } |
| 15 | |
| 16 | do_install() { |
| 17 | oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \ |
| 18 | MANDIR=${mandir} INCLUDEDIR=${includedir} |
| 19 | } |
| 20 | |
| 21 | FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py" |
| 22 | RDEPENDS_${PN} = "python python-subprocess python-textutils" |
| 23 | RRECOMMENDS_${PN} = "kernel-module-hwlat-detector" |