Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "A GNU program for formatting C code" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/indent/" |
| 3 | SECTION = "Applications/Text" |
| 4 | DESCRIPTION = "Indent is a GNU program for beautifying C code, so that \ |
| 5 | it is easier to read. Indent can also convert from one C writing style \ |
| 6 | to a different one. Indent understands correct C syntax and tries to handle \ |
| 7 | incorrect C syntax. \ |
| 8 | Install the indent package if you are developing applications in C and \ |
| 9 | you want a program to format your code." |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | LICENSE = "GPL-3.0-only" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 13 | DEPENDS = "virtual/gettext" |
| 14 | |
| 15 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \ |
| 16 | file://0001-src-indent.c-correct-the-check-for-locale.h.patch \ |
| 17 | file://0001-Makefile.am-remove-regression-dir.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 18 | file://0001-Fix-builds-with-recent-gettext.patch \ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 19 | file://0001-Remove-dead-paren_level-code.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 20 | " |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 21 | SRC_URI[md5sum] = "4764b6ac98f6654a35da117b8e5e8e14" |
| 22 | SRC_URI[sha256sum] = "e77d68c0211515459b8812118d606812e300097cfac0b4e9fb3472664263bb8b" |
| 23 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | inherit autotools gettext texinfo |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | CFLAGS:append:class-native = " -Wno-error=unused-value" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 27 | |
| 28 | BBCLASSEXTEND = "native" |