Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Lua is a powerful light-weight programming language designed \ |
| 2 | for extending applications." |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://doc/readme.html;beginline=307;endline=330;md5=79c3f6b19ad05efe24c1681f025026bb" |
| 5 | HOMEPAGE = "http://www.lua.org/" |
| 6 | |
| 7 | SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \ |
| 8 | file://lua.pc.in \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 9 | file://CVE-2022-28805.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'http://www.lua.org/tests/lua-${PV_testsuites}-tests.tar.gz;name=tarballtest file://run-ptest ', '', d)} \ |
| 11 | " |
| 12 | |
| 13 | # if no test suite matches PV release of Lua exactly, download the suite for the closest Lua release. |
| 14 | PV_testsuites = "5.4.4" |
| 15 | |
| 16 | SRC_URI[tarballsrc.sha256sum] = "164c7849653b80ae67bec4b7473b884bf5cc8d2dca05653475ec2ed27b9ebf61" |
| 17 | SRC_URI[tarballtest.sha256sum] = "04d28355cd67a2299dfe5708b55a0ff221ccb1a3907a3113cc103ccc05ac6aad" |
| 18 | |
| 19 | inherit pkgconfig binconfig ptest |
| 20 | |
| 21 | PACKAGECONFIG ??= "readline" |
| 22 | PACKAGECONFIG[readline] = ",,readline" |
| 23 | |
| 24 | TARGET_CC_ARCH += " -fPIC ${LDFLAGS}" |
| 25 | EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -fPIC' MYLDFLAGS='${LDFLAGS}' 'AR=ar rcD' 'RANLIB=ranlib -D'" |
| 26 | |
| 27 | do_configure:prepend() { |
| 28 | sed -i -e s:/usr/local:${prefix}:g src/luaconf.h |
| 29 | sed -i -e s:lib/lua/:${baselib}/lua/:g src/luaconf.h |
| 30 | } |
| 31 | |
| 32 | do_compile () { |
| 33 | oe_runmake ${@bb.utils.contains('PACKAGECONFIG', 'readline', 'linux-readline', 'linux', d)} |
| 34 | } |
| 35 | |
| 36 | do_install () { |
| 37 | oe_runmake \ |
| 38 | 'INSTALL_TOP=${D}${prefix}' \ |
| 39 | 'INSTALL_BIN=${D}${bindir}' \ |
| 40 | 'INSTALL_INC=${D}${includedir}/' \ |
| 41 | 'INSTALL_MAN=${D}${mandir}/man1' \ |
| 42 | 'INSTALL_SHARE=${D}${datadir}/lua' \ |
| 43 | 'INSTALL_LIB=${D}${libdir}' \ |
| 44 | 'INSTALL_CMOD=${D}${libdir}/lua/5.4' \ |
| 45 | install |
| 46 | install -d ${D}${libdir}/pkgconfig |
| 47 | |
| 48 | sed -e s/@VERSION@/${PV}/ ${WORKDIR}/lua.pc.in > ${WORKDIR}/lua.pc |
| 49 | install -m 0644 ${WORKDIR}/lua.pc ${D}${libdir}/pkgconfig/ |
| 50 | rmdir ${D}${datadir}/lua/5.4 |
| 51 | rmdir ${D}${datadir}/lua |
| 52 | } |
| 53 | |
| 54 | do_install_ptest () { |
| 55 | cp -R --no-dereference --preserve=mode,links -v ${WORKDIR}/lua-${PV_testsuites}-tests ${D}${PTEST_PATH}/test |
| 56 | } |
| 57 | |
| 58 | BBCLASSEXTEND = "native nativesdk" |