Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Command line tool and library for client-side URL transfers" |
| 2 | DESCRIPTION = "It uses URL syntax to transfer data to and from servers. \ |
| 3 | curl is a widely used because of its ability to be flexible and complete \ |
| 4 | complex tasks. For example, you can use curl for things like user authentication, \ |
| 5 | HTTP post, SSL connections, proxy support, FTP uploads, and more!" |
| 6 | HOMEPAGE = "https://curl.se/" |
| 7 | BUGTRACKER = "https://github.com/curl/curl/issues" |
| 8 | SECTION = "console/network" |
| 9 | LICENSE = "MIT-open-group" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=190c514872597083303371684954f238" |
| 11 | |
| 12 | SRC_URI = "https://curl.se/download/${BP}.tar.xz" |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "2cb9c2356e7263a1272fd1435ef7cdebf2cd21400ec287b068396deb705c22c4" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | |
| 15 | # Curl has used many names over the years... |
| 16 | CVE_PRODUCT = "haxx:curl haxx:libcurl curl:curl curl:libcurl libcurl:libcurl daniel_stenberg:curl" |
| 17 | |
| 18 | inherit autotools pkgconfig binconfig multilib_header |
| 19 | |
| 20 | # Entropy source for random PACKAGECONFIG option |
| 21 | RANDOM ?= "/dev/urandom" |
| 22 | |
| 23 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} libidn openssl proxy random threaded-resolver verbose zlib" |
| 24 | PACKAGECONFIG:class-native = "ipv6 openssl proxy random threaded-resolver verbose zlib" |
| 25 | PACKAGECONFIG:class-nativesdk = "ipv6 openssl proxy random threaded-resolver verbose zlib" |
| 26 | |
| 27 | # 'ares' and 'threaded-resolver' are mutually exclusive |
| 28 | PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares,,,threaded-resolver" |
| 29 | PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli" |
| 30 | PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual" |
| 31 | PACKAGECONFIG[dict] = "--enable-dict,--disable-dict," |
| 32 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls" |
| 33 | PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher," |
| 34 | PACKAGECONFIG[imap] = "--enable-imap,--disable-imap," |
| 35 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 36 | PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5" |
| 37 | PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap," |
| 38 | PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps," |
| 39 | PACKAGECONFIG[libgsasl] = "--with-libgsasl,--without-libgsasl,libgsasl" |
| 40 | PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2" |
| 41 | PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2" |
| 42 | PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls" |
| 43 | PACKAGECONFIG[mqtt] = "--enable-mqtt,--disable-mqtt," |
| 44 | PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2" |
| 45 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl" |
| 46 | PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3," |
| 47 | PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy," |
| 48 | PACKAGECONFIG[random] = "--with-random=${RANDOM},--without-random" |
| 49 | PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump" |
| 50 | PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp," |
| 51 | PACKAGECONFIG[smb] = "--enable-smb,--disable-smb," |
| 52 | PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp," |
| 53 | PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss" |
| 54 | PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet," |
| 55 | PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp," |
| 56 | PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver,,,,ares" |
| 57 | PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose" |
| 58 | PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib" |
| 59 | PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd" |
| 60 | |
| 61 | EXTRA_OECONF = " \ |
| 62 | --disable-libcurl-option \ |
| 63 | --disable-ntlm-wb \ |
| 64 | --enable-crypto-auth \ |
| 65 | --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \ |
| 66 | --without-libpsl \ |
| 67 | --enable-debug \ |
| 68 | --enable-optimize \ |
| 69 | --disable-curldebug \ |
| 70 | ${@'--without-ssl' if (bb.utils.filter('PACKAGECONFIG', 'gnutls mbedtls nss openssl', d) == '') else ''} \ |
| 71 | " |
| 72 | |
| 73 | do_install:append:class-target() { |
| 74 | # cleanup buildpaths from curl-config |
| 75 | sed -i \ |
| 76 | -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ |
| 77 | -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \ |
| 78 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 79 | -e 's|${@" ".join(d.getVar("DEBUG_PREFIX_MAP").split())}||g' \ |
| 80 | ${D}${bindir}/curl-config |
| 81 | } |
| 82 | |
| 83 | PACKAGES =+ "lib${BPN}" |
| 84 | |
| 85 | FILES:lib${BPN} = "${libdir}/lib*.so.*" |
| 86 | RRECOMMENDS:lib${BPN} += "ca-certificates" |
| 87 | |
| 88 | FILES:${PN} += "${datadir}/zsh" |
| 89 | |
| 90 | inherit multilib_script |
| 91 | MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config" |
| 92 | |
| 93 | BBCLASSEXTEND = "native nativesdk" |