Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | DESCRIPTION = "The PCRE library is a set of functions that implement regular \ |
| 2 | expression pattern matching using the same syntax and semantics as Perl 5. PCRE \ |
| 3 | has its own native API, as well as a set of wrapper functions that correspond \ |
| 4 | to the POSIX regular expression API." |
| 5 | SUMMARY = "Perl Compatible Regular Expressions" |
| 6 | HOMEPAGE = "http://www.pcre.org" |
| 7 | SECTION = "devel" |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=7e4937814aee14758c1c95b59c80c44d" |
| 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \ |
| 11 | file://pcre-cross.patch \ |
| 12 | file://fix-pcre-name-collision.patch \ |
| 13 | file://run-ptest \ |
| 14 | file://Makefile \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "ed91be292cb01d21bc7e526816c26981" |
| 18 | SRC_URI[sha256sum] = "51679ea8006ce31379fb0860e46dd86665d864b5020fc9cd19e71260eef4789d" |
| 19 | |
| 20 | S = "${WORKDIR}/pcre-${PV}" |
| 21 | |
| 22 | PROVIDES += "pcre" |
| 23 | DEPENDS += "bzip2 zlib" |
| 24 | |
| 25 | PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline," |
| 26 | |
| 27 | BINCONFIG = "${bindir}/pcre-config" |
| 28 | |
| 29 | inherit autotools binconfig-disabled ptest |
| 30 | |
| 31 | EXTRA_OECONF = "\ |
| 32 | --enable-newline-is-lf \ |
| 33 | --enable-rebuild-chartables \ |
| 34 | --enable-utf8 \ |
| 35 | --with-link-size=2 \ |
| 36 | --with-match-limit=10000000 \ |
| 37 | " |
| 38 | |
| 39 | # Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to |
| 40 | # set CFLAGS_FOR_BUILD, required for the libpcre build. |
| 41 | BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}" |
| 42 | CFLAGS += "-D_REENTRANT" |
| 43 | CXXFLAGS_append_powerpc = " -lstdc++" |
| 44 | |
| 45 | PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc" |
| 46 | |
| 47 | SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions" |
| 48 | SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API" |
| 49 | SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes" |
| 50 | SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs" |
| 51 | SUMMARY_pcretest = "program for testing Perl-comatible regular expressions" |
| 52 | SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs" |
| 53 | |
| 54 | FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*" |
| 55 | FILES_libpcreposix = "${libdir}/libpcreposix.so.*" |
| 56 | FILES_pcregrep = "${bindir}/pcregrep" |
| 57 | FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1" |
| 58 | FILES_pcretest = "${bindir}/pcretest" |
| 59 | FILES_pcretest-doc = "${mandir}/man1/pcretest.1" |
| 60 | |
| 61 | BBCLASSEXTEND = "native nativesdk" |
| 62 | |
| 63 | do_install_ptest() { |
| 64 | t=${D}${PTEST_PATH} |
| 65 | cp ${WORKDIR}/Makefile $t |
| 66 | cp -r ${S}/testdata $t |
| 67 | for i in pcre_stringpiece_unittest pcregrep pcretest; \ |
| 68 | do cp ${B}/.libs/$i $t; \ |
| 69 | done |
| 70 | for i in RunTest RunGrepTest test-driver; \ |
| 71 | do cp ${S}/$i $t; \ |
| 72 | done |
| 73 | } |