Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "ITS Tool allows you to translate your XML documents with PO files" |
| 2 | HOMEPAGE = "http://itstool.org/" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5" |
| 5 | |
| 6 | inherit autotools python3native |
| 7 | |
| 8 | DEPENDS = "python3-native python3-lxml-native" |
| 9 | |
| 10 | SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2" |
| 11 | SRC_URI[md5sum] = "655c6f78fc64faee45adcc45ccc5a57e" |
| 12 | SRC_URI[sha256sum] = "100506f8df62cca6225ec3e631a8237e9c04650c77495af4919ac6a100d4b308" |
| 13 | |
| 14 | do_install_append() { |
| 15 | # fix shebang of main script |
| 16 | sed -i 's:${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}:${bindir}/${PYTHON_PN}:g' ${D}${bindir}/itstool |
| 17 | } |
| 18 | |
| 19 | BBCLASSEXTEND = "native" |
| 20 | |
| 21 | RDEPENDS_${PN} += "python3 python3-lxml" |
| 22 | |