Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Display or change ethernet card settings" |
| 2 | DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces." |
| 3 | HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216" |
| 8 | |
| 9 | SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \ |
| 10 | file://run-ptest \ |
| 11 | file://avoid_parallel_tests.patch \ |
| 12 | " |
| 13 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 14 | SRC_URI[md5sum] = "79cff0d4af62b030ad28be90414b5c4a" |
| 15 | SRC_URI[sha256sum] = "8ad6cb30f6e1767d9d23a5cb5f606f3b51f83e85ebf0153c1506194f6709e90b" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 16 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame^] | 17 | UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/" |
| 18 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 19 | inherit autotools ptest bash-completion |
| 20 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 21 | RDEPENDS_${PN}-ptest += "make" |
| 22 | |
| 23 | do_compile_ptest() { |
| 24 | oe_runmake buildtest-TESTS |
| 25 | } |
| 26 | |
| 27 | do_install_ptest () { |
| 28 | cp ${B}/Makefile ${D}${PTEST_PATH} |
| 29 | install ${B}/test-cmdline ${D}${PTEST_PATH} |
| 30 | install ${B}/test-features ${D}${PTEST_PATH} |
| 31 | install ${B}/ethtool ${D}${PTEST_PATH}/ethtool |
| 32 | sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile |
| 33 | } |