blob: 1a041101bd2089045643052009f0df33699a27dd [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Utility to test for faulty memory subsystem"
2HOMEPAGE = "http://pyropus.ca/software/memtester/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
7
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05008SRC_URI = "http://pyropus.ca/software/memtester/old-versions/${BP}.tar.gz \
9 file://Makefile.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010 "
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050011SRC_URI[md5sum] = "674a8a88ff54bdb229ca4148218a41f1"
12SRC_URI[sha256sum] = "8ed52b0d06d4aeb61954994146e2a5b2d20448a8f3ce3ee995120e6dbde2ae37"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050013
14do_compile () {
15 echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
16 echo '${CC} ${LDFLAGS}' > conf-ld
17 oe_runmake
18}
19
20do_install () {
21 install -d ${D}${bindir}
22 install -d ${D}${mandir}/man8
23 install -m 0755 memtester ${D}${bindir}/
24 install -m 0755 memtester.8 ${D}${mandir}/man8/
25}