blob: af8402053236478bca63eef25ed25930da77fac7 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
4 file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
5
Patrick Williamsf1e5d692016-03-30 15:21:19 -05006SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz \
7 file://0001-third_party-threads-Use-PTHREAD_MUTEX_RECURSIVE-by-d.patch \
8 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009SRC_URI[md5sum] = "c0d802bc3d0aba87c51e423a3a8bdd69"
10SRC_URI[sha256sum] = "cbab0e926515064e818bf089a5af04be33307e5f40d07659fb40d59b2bfe20aa"
11
12inherit cmake distro_features_check lib_package
13
14# This should be overridden per-machine to reflect the capabilities of the GL
15# stack.
16PACKAGECONFIG ??= "glx"
17
18# libx11 requires x11 in DISTRO_FEATURES.
19REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'glx', 'x11', '', d)}"
20
21# I say virtual/libgl, actually wants gl.pc
22PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,-Dwaffle_has_glx=0,virtual/libgl libx11"
23
24# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
25# DISTRO_FEATURE.
26PACKAGECONFIG[wayland] = "-Dwaffle_has_wayland=1,-Dwaffle_has_wayland=0,virtual/libgl wayland"
27
28# I say virtual/libgl, actually wants gbm.pc egl.pc
29PACKAGECONFIG[gbm] = "-Dwaffle_has_gbm=1,-Dwaffle_has_gbm=0,virtual/libgl udev"
30
31# I say virtual/libgl, actually wants egl.pc
32PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=1,-Dwaffle_has_x11_egl=0,virtual/libgl libxcb"
33
34FILES_${PN}-dev += "${datadir}/cmake/Modules/FindWaffle.cmake \
35 ${libdir}/cmake/Waffle/"