Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Userspace NFS server v3 protocol" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 2 | DESCRIPTION = "UNFS3 is a user-space implementation of the NFSv3 server \ |
| 3 | specification. It provides a daemon for the MOUNT and NFS protocols, which \ |
| 4 | are used by NFS clients for accessing files on the server." |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 5 | HOMEPAGE = "https://github.com/unfs3/unfs3" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 6 | SECTION = "console/network" |
| 7 | LICENSE = "unfs3" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e" |
| 9 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 10 | DEPENDS = "flex-native bison-native flex" |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 11 | DEPENDS += "libtirpc" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | DEPENDS:append:class-nativesdk = " flex-nativesdk" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 13 | |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 14 | ASNEEDED = "" |
| 15 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 16 | S = "${WORKDIR}/git" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https;branch=master \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 18 | file://unfs3_parallel_build.patch \ |
| 19 | file://alternate_rpc_ports.patch \ |
| 20 | file://fix_pid_race_parent_writes_child_pid.patch \ |
| 21 | file://fix_compile_warning.patch \ |
| 22 | file://rename_fh_cache.patch \ |
| 23 | file://relative_max_socket_path_len.patch \ |
| 24 | file://tcp_no_delay.patch \ |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 25 | file://0001-daemon.c-Libtirpc-porting-fixes.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | file://0001-attr-fix-utime-for-symlink.patch \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 27 | file://0001-Add-listen-action-for-a-tcp-socket.patch \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 28 | file://no-yywrap.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | " |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 30 | SRCREV = "c12a5c69a8d59be6916cbd0e0f41c159f1962425" |
| 31 | UPSTREAM_CHECK_GITTAGREGEX = "unfs3\-(?P<pver>.+)" |
| 32 | |
| 33 | PV = "0.9.22+${SRCPV}" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |
| 36 | |
| 37 | inherit autotools |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | EXTRA_OECONF:append:class-native = " --sbindir=${bindir}" |
| 39 | CFLAGS:append = " -I${STAGING_INCDIR}/tirpc" |
| 40 | EXTRA_OECONF:append = " LIBS=-ltirpc" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 41 | |
| 42 | # Turn off these header detects else the inode search |
| 43 | # will walk entire file systems and this is a real problem |
| 44 | # if you have 2 TB of files to walk in your file system |
| 45 | CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no" |