blob: 2ed08110f4441f10aadce4beddeb0a6dbb9767e3 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Network benchmark tool"
2DESCRIPTION = "\
3iperf is a tool for active measurements of the maximum achievable bandwidth \
4on IP networks. It supports tuning of various parameters related to timing, \
5protocols, and buffers. For each test it reports the bandwidth, loss, and \
6other parameters."
7HOMEPAGE = "http://software.es.net/iperf/"
8SECTION = "console/network"
9BUGTRACKER = "https://github.com/esnet/iperf/issues"
10AUTHOR = "ESNET <info@es.net>, Lawrence Berkeley National Laboratory <websupport@lbl.gov>"
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=d098223e44bdd19585315ee75cd9d2d7"
13
14DEPENDS = "openssl"
15
16SRC_URI = "git://github.com/esnet/iperf.git \
17 file://automake-foreign.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018 file://0002-Remove-pg-from-profile_CFLAGS.patch \
19 "
20
21SRCREV = "88d907f7fb58bfab5d086c5da60c922e1c582c92"
22
23S = "${WORKDIR}/git"
24
25inherit autotools
26
27PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools"
28
29CFLAGS += "-D_GNU_SOURCE"
30
31EXTRA_OECONF = "--with-openssl=${RECIPE_SYSROOT}"
32
33BBCLASSEXTEND = "native"