Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Enlightened Sound Daemon" |
| 2 | SECTION = "gpe/base" |
| 3 | LICENSE = "LGPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 5 | DEPENDS = "audiofile" |
| 6 | |
| 7 | inherit gnome |
| 8 | |
| 9 | SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/esound/0.2/${P}.tar.bz2;name=archive \ |
| 10 | file://no-docs.patch \ |
| 11 | file://0001-audio_alsa09.c-alsa-drain-fix.patch \ |
| 12 | file://0002-Undefine-open64-and-fopen64.patch \ |
| 13 | file://0003-Use-I-path-in-configure.patch \ |
| 14 | " |
| 15 | SRC_URI[archive.md5sum] = "8d9aad3d94d15e0d59ba9dc0ea990c6c" |
| 16 | SRC_URI[archive.sha256sum] = "5eb5dd29a64b3462a29a5b20652aba7aa926742cef43577bf0796b787ca34911" |
| 17 | |
| 18 | EXTRA_OECONF += " \ |
| 19 | --disable-arts \ |
| 20 | --disable-artstest \ |
| 21 | " |
| 22 | EXTRA_OECONF_remove = "--disable-schemas-install" |
| 23 | |
| 24 | CFLAGS += "-lm" |
| 25 | |
| 26 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 27 | PACKAGECONFIG[libwrap] = "--with-libwrap,--without-libwrap,tcp-wrappers," |
| 28 | PACKAGECONFIG[alsa] = "--enable-alsa --disable-oss,--disable-alsa,alsa-lib," |
| 29 | |
| 30 | PACKAGECONFIG ??= "libwrap alsa \ |
| 31 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 32 | " |
| 33 | PACKAGES =+ "esddsp esd esd-utils" |
| 34 | |
| 35 | FILES_esddsp = "${bindir}/esddsp ${libdir}/libesddsp.so.*" |
| 36 | FILES_esd = "${bindir}/esd" |
| 37 | FILES_esd-utils = "${bindir}/*" |