Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools" |
| 2 | HOMEPAGE = "https://github.com/gperftools/gperftools" |
| 3 | LICENSE = "BSD" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a" |
| 5 | DEPENDS += "libunwind" |
| 6 | |
| 7 | SRCREV = "bf840dec0495e17f5c8403e68e10b9d6bf05c559" |
| 8 | SRC_URI = "git://github.com/gperftools/gperftools \ |
| 9 | file://0001-Support-Atomic-ops-on-clang.patch \ |
| 10 | file://0001-Use-ucontext_t-instead-of-struct-ucontext.patch \ |
| 11 | file://0001-fix-build-with-musl-libc.patch \ |
| 12 | file://0001-include-fcntl.h-for-loff_t-definition.patch \ |
| 13 | file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \ |
| 14 | file://disable_libunwind_aarch64.patch \ |
| 15 | file://sgidef.patch \ |
| 16 | " |
| 17 | |
| 18 | inherit autotools |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | # Disable thumb1 |
| 23 | # {standard input}: Assembler messages: |
| 24 | # {standard input}:434: Error: lo register required -- `ldr pc,[sp]' |
| 25 | # Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed |
| 26 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 27 | |