Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Intel RSTe with Linux OS SSI API Library" |
| 2 | |
| 3 | DESCRIPTION = "Intel Rapid Storage Technology enterprise with Linux OS* Standard Storage Interface API Library. \ |
| 4 | The library allows user to manage storage devices including creating and managing Raid arrays on systems with Intel chipset." |
| 5 | |
| 6 | HOMEPAGE = "http://irstessi.sourceforge.net/" |
| 7 | |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=0413ff365e0bd733c4869a6797551c6f" |
| 10 | |
| 11 | DEPENDS += "sg3-utils" |
| 12 | |
| 13 | SRC_URI = "http://sourceforge.net/projects/irstessi/files/${BPN}.${PV}.tgz \ |
| 14 | file://0001-Use-pragma-once-unconditionally.patch \ |
| 15 | file://0002-Convert-macros-into-functions.patch \ |
| 16 | file://0003-Replace-canonicalize_file_name-with-realpath-API.patch \ |
| 17 | file://0004-engine-Fix-indentation-and-missing-semi-colon.patch \ |
| 18 | file://0005-engine-Define-SENTINEL.patch \ |
| 19 | file://0006-tools-Add-missing-includes-and-use-realpath-instead-.patch \ |
| 20 | file://configure-cflags.patch \ |
| 21 | file://0001-ssieventmonitor-ordered-comparison-between-pointers-.patch \ |
| 22 | " |
| 23 | SRC_URI[md5sum] = "02f16d7cbd30d28034093212906591f5" |
| 24 | SRC_URI[sha256sum] = "e10d283b0f211afb8ebd0bde87c097769613d30a052cdf164753e35e803264c7" |
| 25 | |
| 26 | S ="${WORKDIR}/${BPN}.${PV}" |
| 27 | |
| 28 | inherit autotools-brokensep |
| 29 | CXXFLAGS="-std=gnu++98 -D_GNU_SOURCE" |
| 30 | |
| 31 | do_configure_prepend(){ |
| 32 | ./autogen.sh |
| 33 | } |
| 34 | |
| 35 | RDEPENDS_${PN} += "mdadm" |