Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "GTK+2 standard themes" |
| 2 | HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome" |
| 5 | |
| 6 | LICENSE = "LGPL-2.1" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 8 | |
| 9 | inherit autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even distro_features_check |
| 10 | |
| 11 | ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}" |
| 12 | |
| 13 | DEPENDS += "intltool-native gtk+" |
| 14 | |
| 15 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" |
| 16 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[md5sum] = "b51c362b157b6407303d44f93c31ee11" |
| 20 | SRC_URI[sha256sum] = "61dc87c52261cfd5b94d65e8ffd923ddeb5d3944562f84942eeeb197ab8ab56a" |
| 21 | |
| 22 | EXTRA_OECONF = "--disable-gtk3-engine" |
| 23 | |
| 24 | do_install_append() { |
| 25 | # Only building Adwaita, remove highcontrast files |
| 26 | rm -rf ${D}${prefix}/share/themes/HighContrast \ |
| 27 | ${D}${prefix}/share/icons |
| 28 | |
| 29 | # The libtool archive file is unneeded with shared libs on modern Linux |
| 30 | rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la |
| 31 | } |
| 32 | |
| 33 | # There could be gnome-theme-highcontrast as well but that requires |
| 34 | # gtk+3 and includes lots of icons (is also broken with B != S). |
| 35 | PACKAGES += "gnome-theme-adwaita \ |
| 36 | gnome-theme-adwaita-dark \ |
| 37 | " |
| 38 | |
| 39 | FILES_gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \ |
| 40 | ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so" |
| 41 | |
| 42 | FILES_gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark" |
| 43 | RDEPENDS_gnome-theme-adwaita-dark = "gnome-theme-adwaita" |
| 44 | |
| 45 | # gnome-themes-standard is empty and doesn't exist |
| 46 | RDEPENDS_${PN}-dev = "" |