Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 1 | SUMMARY = "Provider for integration of TPM 2.0 to OpenSSL 3.0" |
| 2 | LICENSE = "BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b75785ac083d3c3ca04d99d9e4e1fbab" |
| 4 | |
| 5 | DEPENDS = "autoconf-archive-native tpm2-tss openssl" |
| 6 | |
| 7 | SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "eedcc0b72ad6d232e6f9f55a780290c4d33a4d06efca9314f8a36d7384eb1dfc" |
| 10 | |
| 11 | inherit autotools pkgconfig |
| 12 | |
| 13 | do_configure:prepend() { |
| 14 | # do not extract the version number from git |
| 15 | sed -i -e 's/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/' ${S}/configure.ac |
| 16 | } |
| 17 | |
| 18 | FILES:${PN} = "\ |
| 19 | ${libdir}/ossl-modules/tpm2.so" |