Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Self-contained ISO 3166-1 country definitions" |
| 2 | HOMEPAGE = "https://pypi.org/project/iso3166/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5e2f4edc7e7408a82e4a1d05f229b695" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "04d02cfcfc18a6f8a9a4edb4d0a55e2e4fc575626c29d702f750de415e88d372" |
| 7 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | inherit pypi python_setuptools_build_meta ptest |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN}-ptest += " \ |
| 15 | ${PYTHON_PN}-pytest \ |
| 16 | " |
| 17 | |
| 18 | do_install_ptest() { |
| 19 | install -d ${D}${PTEST_PATH}/tests |
| 20 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 21 | } |
| 22 | |
| 23 | RDEPENDS:${PN} += "python3-numbers" |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |