Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "A fully featured modbus protocol stack in python" |
| 2 | HOMEPAGE = "https://github.com/riptideio/pymodbus/" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c2223d66c7e674b40527b5a4c35bd76" |
| 5 | DEPENDS += "python3-six-native" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "5ef68c1a109bdb467c830ef003ef2db6494349a5248e4af946fe21c9eefe7e74" |
| 8 | S = "${WORKDIR}/pymodbus-${PV}" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | PACKAGECONFIG ??= "" |
| 13 | PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio" |
| 14 | PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio" |
| 15 | PACKAGECONFIG[tornado] = ",,,python3-tornado" |
| 16 | PACKAGECONFIG[twisted] = ",,,python3-twisted-conch" |
| 17 | PACKAGECONFIG[redis] = ",,,python3-redis" |
| 18 | PACKAGECONFIG[sql] = ",,,python3-sqlalchemy" |
| 19 | |
| 20 | RDEPENDS:${PN} += " \ |
| 21 | python3-asyncio \ |
| 22 | python3-core \ |
| 23 | python3-io \ |
| 24 | python3-json \ |
| 25 | python3-logging \ |
| 26 | python3-math \ |
| 27 | python3-netserver \ |
| 28 | " |
| 29 | |
| 30 | RDEPENDS:${PN} += " \ |
| 31 | python3-pyserial \ |
| 32 | python3-six \ |
| 33 | " |
| 34 | |
| 35 | |