Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Pyzmq provides Zero message queue access for the Python language" |
| 2 | HOMEPAGE = "http://zeromq.org/bindings:python" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "BSD-3-Clause & LGPL-3.0-only" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \ |
| 5 | file://COPYING.LESSER;md5=12c592fa0bcfff3fb0977b066e9cb69e" |
| 6 | DEPENDS = "zeromq" |
| 7 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | SRC_URI += "file://club-rpath-out.patch" |
Patrick Williams | 93c203f | 2021-10-06 16:15:23 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "8eddc033e716f8c91c6a2112f0a8ebc5e00532b4a6ae1eb0ccc48e027f9c671c" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | inherit pypi pkgconfig python_setuptools_build_meta |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 13 | RDEPENDS:${PN} += " \ |
| 14 | ${PYTHON_PN}-multiprocessing \ |
| 15 | ${PYTHON_PN}-json \ |
| 16 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | do_compile:prepend() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | echo [global] > ${S}/setup.cfg |
| 20 | echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg |
| 21 | echo have_sys_un_h = True >> ${S}/setup.cfg |
| 22 | echo skip_check_zmq = True >> ${S}/setup.cfg |
| 23 | echo libzmq_extension = False >> ${S}/setup.cfg |
| 24 | echo no_libzmq_extension = True >> ${S}/setup.cfg |
| 25 | } |