Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Internationalised Domain Names in Applications" |
| 2 | HOMEPAGE = "https://github.com/kjd/idna" |
| 3 | LICENSE = "BSD-3-Clause & Python-2.0 & Unicode-TOU" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=239668a7c6066d9e0c5382e9c8c6c0e1" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "9d643ff0a55b762d5cdb124b8eaa99c66322e2157b69160bc32796e824360e6d" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | # Remove bundled egg-info |
| 11 | do_compile:prepend() { |
| 12 | rm -rf ${S}/idna.egg-info |
| 13 | } |
| 14 | |
| 15 | RDEPENDS:${PN}:class-target = "\ |
| 16 | ${PYTHON_PN}-codecs \ |
| 17 | " |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |