Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | LICENSE = "LGPLv2.1 & GPLv2 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \ |
| 6 | file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \ |
| 7 | file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \ |
| 8 | " |
| 9 | |
| 10 | inherit module |
| 11 | |
| 12 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux' |
| 13 | |
| 14 | #https://lttng.org/files/lttng-modules/lttng-modules-2.10.7.tar.bz2 |
| 15 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 16 | file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ |
| 17 | file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | " |
| 19 | |
Brad Bishop | f8caae3 | 2019-03-25 13:13:56 -0400 | [diff] [blame^] | 20 | SRC_URI[md5sum] = "09df0ac2e8f245740a2f32411d10c0d1" |
| 21 | SRC_URI[sha256sum] = "a1855bbd02d0f71ebd180e9872309862036624f012442ab9cc5852eb60340145" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | |
| 23 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 24 | |
| 25 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 26 | |
| 27 | do_install_append() { |
| 28 | # Delete empty directories to avoid QA failures if no modules were built |
| 29 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 30 | } |
| 31 | |
| 32 | python do_package_prepend() { |
| 33 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 34 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 35 | } |
| 36 | |