Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2012 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "Provides a wrapper in Python to LDAP" |
| 5 | DESCRIPTION = "This module provides access to the LDAP \ |
| 6 | (Lightweight Directory Access Protocol) through Python operations \ |
| 7 | instead of C API. The module mainly acts as a wrapper for the \ |
| 8 | OpenLDAP 2.x libraries. Errors will appear as exceptions." |
| 9 | |
| 10 | LICENSE = "PSF" |
| 11 | HOMEPAGE = "http://www.python-ldap.org/" |
| 12 | DEPENDS = "python openldap cyrus-sasl" |
| 13 | |
| 14 | PYPI_PACKAGE = "python-ldap" |
| 15 | inherit pypi setuptools |
| 16 | |
| 17 | LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b" |
| 18 | SRC_URI[md5sum] = "6108e189a44eea8bc7d1cc281c222978" |
| 19 | SRC_URI[sha256sum] = "824fde180a53772e23edc031c4dd64ac1af4a3eade78f00d9d510937d562f64e" |
| 20 | |
| 21 | do_configure_prepend() { |
| 22 | sed -i -e 's:^library_dirs =.*::' setup.cfg |
| 23 | sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg |
| 24 | } |
| 25 | |
| 26 | RDEPENDS_${PN} = " \ |
| 27 | ${PYTHON_PN}-pprint \ |
| 28 | ${PYTHON_PN}-threading \ |
| 29 | " |