Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | inherit setuptools3 |
| 2 | require python-cython.inc |
| 3 | |
| 4 | RDEPENDS_${PN} += "\ |
| 5 | python3-setuptools \ |
| 6 | " |
| 7 | |
| 8 | # running build_ext a second time during install fails, because Python |
| 9 | # would then attempt to import cythonized modules built for the target |
| 10 | # architecture. |
| 11 | DISTUTILS_INSTALL_ARGS += "--skip-build" |
| 12 | |
| 13 | do_install_append() { |
| 14 | # rename scripts that would conflict with the Python 2 build of Cython |
| 15 | mv ${D}${bindir}/cython ${D}${bindir}/cython3 |
| 16 | mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3 |
| 17 | mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3 |
| 18 | } |